This project has moved. For the latest updates, please go here.

Program only seems to work sometimes?

Mar 25, 2015 at 2:13 PM
Hey folks,

This program is great when it works but that only seems to be about 50% of the time for whatever reason. Many times I'll come back to my PC after stepping away and things will have gone idle even though I had the program running.

I'm running Windows 8.1.


Does anybody know what I need to go to get this working all the time?
Coordinator
Mar 25, 2015 at 7:18 PM
Hi,

What do you have Move Mouse configured to do? Have you configured it to automatically pause and resume?

sw3103


Mar 25, 2015 at 7:30 PM
Yes, I have a blackout period scheduled but the problems occur when it's not supposed to be blacked out.

Coordinator
Mar 26, 2015 at 2:55 PM

Could you post the contents of this file so that I can see what’s configured?

%AppData%\Ellanet\Move Mouse\Move Mouse.xml

Jun 25, 2015 at 7:07 PM
I've found that when I have an application running as administrator, sometimes Move Mouse doesn't work. I started running Move Mouse as admin and no more problems.
Jun 25, 2015 at 7:10 PM
crusc13 wrote:
I've found that when I have an application running as administrator, sometimes Move Mouse doesn't work. I started running Move Mouse as admin and no more problems.
Thanks, I'll give this a try to see if it helps my problem at all. I forgot all about this post until just now, sorry for never providing the XML. Below is my output:


<settings>
<second_delay>240</second_delay>
<move_mouse_pointer>True</move_mouse_pointer>
<stealth_mode>False</stealth_mode>
<enable_static_position>True</enable_static_position>
<x_static_position>2281</x_static_position>
<y_static_position>258</y_static_position>
<click_left_mouse_button>False</click_left_mouse_button>
<send_keystroke>True</send_keystroke>
<keystroke>{MULTIPLY}</keystroke>
<pause_when_mouse_moved>False</pause_when_mouse_moved>
<automatically_resume>False</automatically_resume>
<resume_seconds>300</resume_seconds>
<disable_on_battery>False</disable_on_battery>
<enable_hotkey>False</enable_hotkey>
<hotkey>
</hotkey>
<automatically_start_on_launch>True</automatically_start_on_launch>
<automatically_launch_on_logon>True</automatically_launch_on_logon>
<minimise_on_pause>False</minimise_on_pause>
<minimise_on_start>False</minimise_on_start>
<minimise_to_system_tray>False</minimise_to_system_tray>
<activate_application>False</activate_application>
<activate_application_title>
</activate_application_title>
<last_update_check>2015-Jun-22 07:03:02</last_update_check>
<system_tray_warning_shown>True</system_tray_warning_shown>
<execute_start_script>False</execute_start_script>
<execute_interval_script>False</execute_interval_script>
<execute_pause_script>False</execute_pause_script>
<show_script_execution>False</show_script_execution>
<script_language>PowerShell</script_language>
<script_editor>C:\WINDOWS\System32\notepad.exe</script_editor>
<schedules />
<blackouts>
<blackout>
  <start>16:40:00</start>
  <end>06:35:00</end>
</blackout>
</blackouts>
</settings>
Coordinator
Jun 30, 2015 at 10:13 AM
Edited Jun 30, 2015 at 10:14 AM
The machine I use to develop Move Mouse is Windows 8.1, so I don't think that is necessarily the issue.

I'll use your config on my Move Mouse for a day or two to see if it runs OK. From first glance - nothing seems obvious.

A couple of points:
  • The interval is set to 240 seconds. I assume your screensaver/monitor timeout is less than that?
  • Your are sending the {MULTIPLY} keystroke, which is actually a *. I assume that is not disrupting anything in your session?
Marked as answer by sw3103 on 3/20/2017 at 2:35 PM